






Contents
Overview	1
Learning Outcomes	1
PDF Templates	1
Create form fields in the pdf	1
Create the form fields for populating	5
Additional steps:	10
Adjusting the PDF: additional steps	10
Placing numbers or letters in boxes	10
Formatting dates	11
Formatting text	12
Create the PDF in Insolvency	12
Open the SP in SSMS	16
Additional steps:	18
Extracting data	19
Adding two fields together	19
Adding a segment of text	20
Adding two fields plus text	20
Splitting a date into days, months and years	22
Convert a date	23
Reformatting formatted address fields	23
Final steps:	23
Testing	28


< Manual Title>

ii	
i
PDF Templates
[bookmark: _Toc448500122]Overview 
Insolvency can produce standard forms from PDF files.
Using the system interface we will look at adding pdf files as reports in the system.
We will also look at setting the options including specifying the job types and specific operations for these pdf reports.
[bookmark: _Toc448500123]Learning Outcomes
At the completion of this course, you will be able to:
Prepare a new pdf
Set the properties of the pdf.
Add the pdf to the system.
Set the job types and specific operations for the pdf.
[bookmark: _Toc448500124]PDF Templates
This section assumes you have a copy of Adobe Acrobat, but any other PDF creator which can create form fields would suffice.  However, the exact procedure, menu items, etc., will of course be different.  You may need to refer to the application’s manual.
It is also assumed that the pdf does not already have form fields defined in it, or that the form fields are secured.  The issue of secured pdf’s is not dealt with in this document.  
It should be possible to scan a document which has a number of boxes for completion, save that document in .pdf format, then add form fields to that document.  Companies House, HM Revenue and Customs, HM Land Registry and other forms publishers now publish all their forms in .pdf format only.  The examples shown below are taken directly from Companies House.
[bookmark: _Toc448500125]Create form fields in the pdf
1. Open the PDF ‘paper’ form (i.e., 
2. In Acrobat, go to Tools > Forms > Create
[image: ]
3. Select Use an existing file:
[image: ]
4. Select Use the current document:
[image: ]
5. Acrobat now creates the various form fields and changes to form editing mode:
[image: ]
	NOTE If you allow the pdf creator application to automatically create form fields, you will need to reformat those fields.  Some parts of the form may be incorrectly identified as fields and will therefore need deleting.  Other fields will need adjusting for size.  All fields will need renaming.


An alternative procedure would be to manually create the form fields.
6. Open the pdf and go to go to Tools > Forms > Edit.
7. You should receive a request to automatically detect the fields.  Click ‘No’.
[image: ]
	NOTE: If you click ‘Yes’ at this stage, the same procedure as above, with the application automatically detecting the form fields, will be started. 


8. You may now add the different styles of field to the form from either
a) the ‘Tasks’ taskbar, or
b) the Forms menu
[image: ]


9. The most common field appears to be the text field:
[image: ]
10. Click in the form …
[image: ]
… then drag to the approximate size of the field.
[image: ]
11. When you release the mouse button, the field is created with a generic name (in this case, ‘Text1’):
[image: ]
12. Continue until all the fields you need have been created.
13. The correct naming of the fields is detailed in the following section.
	NOTE: The usual distinction between checkboxes and radio buttons applies here:

	Checkboxes:

	[image: ]

	Radio Buttons (which will also require the group of buttons to be named in addition to the buttons themselves.
	[image: ]


[bookmark: _Toc448500126]Create the form fields for populating
Although the PDF forms package being used may create forms, they may not be in the correct place and definitely will not be correctly named if they were automatically created.  This will now have to be corrected.  The exact method of correction will depend on the software being used.  For the purpose of this example, Acrobat is again being used to demonstrate the principles.
1. [image: ]Rename fields where the contents matches a replacefield to that replacefield, e.g., name of company or name of appointees (in this case, the company’s Registered Number and its name):

2. Rename fields where the field contents do not match a replacefield or have to be manipulated (e.g., the name of the secured creditor). 
[image: ]
3. Set the font size and type.
Generally, the fields are set so that the font size varies with the size of the field and the amount of text assigned to the field.  You may find this looks untidy.
Select all or a number of fields, right click any one of them and select ‘Properties’:
[image: ]
In the dialog box shown, select the Appearance tab and make the appropriate selection from the Font Size and Font:
[image: ]
	NOTE: Options which have different selections in different fields when selected together are shown as [image: ].  Font and Font Size will generally show as “Varies” where different fields have different font settings.



	NOTE: Not all tabs are shown as certain options are not available with several field selected at once.


4. Align the fields
With all or some of the fields selected as before, right click any one of them and select either
Set Fields to Same Size to set the height, width or both of the selected fields:
[image: ]

Alternatively, select Align, Distribute or Center:
[image: ]
For instance, set both the width and height to be the same then align left will give you a set of fields with the same dimensions.
5. Adjust the wording.
In this form, there is an ‘I / We’ which has not been identified as a field:
[image: ]
Create a new field which covers the wording:
[image: ]
6. This field is also the same height as the adjacent field and has been aligned with it so that the formatting remains consistent.
7. Rename the field.  In this case, as there’s a suitable replacefield, we’ll use [RF_APPOINTEE_I_WE_UPPER]:
[image: ]
8. [image: ]For the appearance, we’ll make the field white to obscure the background text:



9. We’ll also align the text of this field to the right:
[image: ]
	NOTE: The fields will probably need to be re-adjusted following testing.


10. Once all the required fields have been entered, amended and adjusted, ‘form editing’ can be closed and the file saved.
	[image: ]NOTE: So that the PDF may be imported, the file must be saved in the root Forms folder:





	[image: ]TIP: If you are using Acrobat to manipulate the form, you can also adjust the text on the form:
With Form Editing closed, go to Tools > Content > Edit Object.  Click on the text you wish to move: a blue box will surround the text if you can move it:
[image: ]You may find too much text gets selected, in which case try manually selecting an area.

Hover the cursor over the selected section.  The cursor will change:

[image: ]You can now click and drag that section.  Release the mouse button so fix the position.

Other pdf editing applications may also have this functionality.


[bookmark: _Toc448500127]Additional steps:
Save As > Reduced Size PDF
Decreases the size of the final PDF so that it takes less time to download over an intranet (for remote offices)
Save As > Reader Extended PDF
Allows the final PDF to be saved with form data in the free Adobe Reader.
[bookmark: _Toc448500128]Adjusting the PDF: additional steps
There may be some additional work to do on the form fields. It’s likely that the output will not match the desired fields on the form, or you wish to force the formatting (although this can be done by SQL scripting in the SP). 
[bookmark: _Toc448500129]Placing numbers or letters in boxes
The usual scenario here is a form from Companies House:
[image: ]
Right-click the form field and select properties.
In the Options tab, deselect all options except ‘Comb of’.  Enter the number of boxes available (in this case, 8):
[image: ]
[bookmark: _Toc448500130]Formatting dates
[image: ]Not usually necessary unless you really need to manipulate the date format, usually when manually entering dates instead of using the replacefield code.
From the Properties dialog, select Format > Date and enter a Custom format as required:


[bookmark: _Toc448500131]Formatting text
Generally, text fields are formatted properly but, if you need to make a text field always in caps, from the Properties dialog, select Format > Custom > Edit and insert the javascript code shown below:
[image: ]
[bookmark: _Toc448500132]Create the PDF in Insolvency
Once the PDF has been adjusted appropriately and saved, it must next be made available to the application.
1. Go to Manage Document Templates and select All Shared > Forms:
[image: ]

2. Click [image: ] and select the form prepared previously (in this case, Form 2.30B(CH).
In the Details tab, select:
[image: ]
3. In the Display Options tab, select:
[image: ]
	NOTE: The actual selection here will depend on the form type.  In this case, form 2.30B (CH) is for (England and Wales) Administrations only – Scottish Administrations have their own form. 


4. In the User Prompts tab, select:
[image: ]
	NOTE: This enables a selection to be made for the appointee signing the form where there is more than one appointee, but also for the ‘presenter’ information at the bottom of the form.  



	NOTE: The User Inputs tab is left blank in this example but enables ‘custom’ replacefields to be entered to appear in the Document Production Wizard.


5. In the Advanced tab, enter a name for the Stored Procedure (“SP”) to be associated with the form, for example:
[image: ]
	NOTE: the name could be anything here but, to keep the resulting SP in line with other similar SPs, it is recommended that the name starts with ‘pdfsp_’ then the name of the form, with underscores replacing spaces.


6. We now need to enter prompts for form fields which have no replacecode associated with them and for the user will be required to enter information.
As an example, the S120 notice requires the following information:
A contact at the insolvent company, which may not be the director
The name of the insolvent company’s pension scheme
The number of the pension scheme
As none of these details is held in the company’s data in the application, the user must enter these details manually.
7. Click [image: ].  The following screen is displayed:
[image: ]
8. From here, you may specify the type of entry required:
Choose an option
Enter a number or text
Enter a date
Enter several lines of text

	NOTE: The SQL Statement option has not yet been implemented.


9. You should also enter a prompt for the users who will be completing this form, so that they know what to enter.  This prompt will be shown in the Document Production Wizard.
In this example, we will require the user to enter a contact name, so the following example is used
[image: ]
Click [image: ] to add this prompt to the SP.
Any number of entries may be created here, but for the current example, we only need three.  The first prompt has been created, so we will now create the prompts for the pension scheme name …
[image: ]
… and the pension scheme number:
[image: ]
Click [image: ] to add each prompt as before.
10. Your screen should now look something like this:
[image: ]
11. Click [image: ] to create the basic SP.
12. Enter a location to save the SP file and click [image: ].
[bookmark: _Toc448500133]Open the SP in SSMS
Now the basic Stored Procedure has been created, we now need to import the draft SP into SSMS to make any final adjustments, such as:
Reformatting the entered data
Combining or splitting fields
[image: ]Appending text to a field
In this example, we will continue work on the S120 notice.
1. Launch SSMS and select File > Open > File:


2. Navigate to where you saved the draft SP above, select the file and click [image: ].
The SP is opened in SSMS, which will look similar to that shown in Listing 1 below:
	Listing 1

	
IF EXISTS ( SELECT  *
            FROM    sysobjects
            WHERE   id = OBJECT_ID(N'[dbo].[pdfsp_S120_notice.sql]')
                    AND OBJECTPROPERTY(id, N'IsProcedure') = 1 ) 
    DROP PROCEDURE [dbo].[pdfsp_S120_notice.sql]
GO

SET QUOTED_IDENTIFIER  ON
SET ANSI_NULLS  ON
GO

CREATE PROCEDURE dbo.pdfsp_S120_notice.sql
    @AdminID INT
  , @SignatoryInClause NVARCHAR(MAX) = NULL
  , @Company_Contact NVARCHAR(MAX) = NULL
  , @Name_Pension_Scheme NVARCHAR(MAX) = NULL
  , @Pension_Scheme_Number NVARCHAR(MAX) = NULL

AS 

    SET NOCOUNT ON

    CREATE TABLE dbo.#Data ( ID INT NOT NULL )
    IF NOT @SignatoryInClause IS NULL 
        EXEC dbo.usp_Split @SignatoryInClause

    DECLARE @Data TABLE
        (
          Title NVARCHAR(200)
        , Value NVARCHAR(MAX)
        )

	--Return results
    SELECT  *
    FROM    @Data

    SET NOCOUNT OFF

    RETURN @@ERROR
GO

SET QUOTED_IDENTIFIER  OFF
SET ANSI_NULLS  ON
GO

GRANT  EXECUTE  ON [dbo].[pdfsp_S120_notice.sql]  TO [insol2_users]
GO



You should note that this listing has been formatted to improve readability: your draft SP may appear differently but should contain the same information.
The following points should be noted:
The data to be displayed in the pdf is held in a table, @Data.  Data to be manually or programmatically entered into the pdf is entered in pairs: the first element being the data, the second being the field name in the pdf.  


The data is then returned by selecting all the table entries in the table:
SELECT *
FROM @Data
The section 
CREATE TABLE dbo.#Data ( ID INT NOT NULL )
IF NOT @SignatoryInClause IS NULL 
    EXEC dbo.usp_Split @SignatoryInClause
has been added to the draft SP because the User Prompt ‘Select One Signatory Only’ was selected above.  This will, of course, change depending on which User Prompts have been selected prior to creating the draft SP.
The variable @SignatoryInClause NVARCHAR(MAX) = NULL  to hold the signatory’s name has also been added.
The section to obtain the Signatory’s details has also been added:
CREATE TABLE dbo.#Data ( ID INT NOT NULL )
IF NOT @SignatoryInClause IS NULL 
EXEC dbo.usp_Split @SignatoryInClause
A variable for the Court name, @NameOfCourt NVARCHAR(MAX) = NULL, has also been added.
3. We now need to create the various SQL clauses to hold the data from the Document Production Wizard:
The contact at the insolvent company ( @Company_Contact )
The name of the company’s pension scheme (@Name_Pension_Scheme )
The number of the pension scheme (@Pension_Scheme_Number )
The following listing shows the entries to be created:
	Listing 2

	
Insert Into @Data
VALUES ('CoContactName', @Company_Contact)

Insert Into @Data
VALUES ('NameOfPensionScheme', @Name_Pension_Scheme)

Insert Into @Data
VALUES ('PensNumber', @Pension_Scheme_Number)



This is all that is required to connect an entry in the Document Production Wizard to the form field in the pdf.
[bookmark: _Toc448500134]Additional steps:
There may be additional fields in the pdf for which there is data in the application but no replacefields.  If that information may be extracted or manipulated by a simple SQL script, it may also be added to the draft SP.
We will look at a number of examples from various forms.


[bookmark: _Toc448500135]Extracting data
In this example, a telephone number is extracted from General > Addresses > Numbers.  Form HR1 requires the telephone number of the company to be provided:
[image: ]
The following listing shows an example script to extract this information:
	Listing 3

	
Insert Into @Data 
SELECT 'Employers telephone number', N.Number
FROM 	Admin_Number AN INNER JOIN
	Number N ON AN.NumberID = N.NumberID INNER JOIN
	NumberType NT ON N.NumberTypeID = NT.NumberTypeID
	WHERE (NT.NumberTypeID = 1) AND (AN.AdminID = @AdminID)



[bookmark: _Toc448500136]Adding two fields together
In this example, the DX Address and DX Number fields are added together for formatting purposes only in certain forms, for example, the presenter’s name and address in some Companies House forms:
[image: ]
In the listing shown below, the Practice DX Number is appended to the Practice DX Address
	Listing 4

	
INSERT INTO @Data
SELECT	'DX' , 
	'DX: '
	+ ( SELECT  Number.Number
	    FROM    Practice_Number
                    INNER JOIN Number ON Practice_Number.NumberID = Number.NumberID
                    INNER JOIN Admin ON Practice_Number.PracticeID = Admin.PracticeID
            WHERE   ( Number.NumberTypeID = 7 )
                    AND ( Admin.AdminID = @AdminID )
          )
        + ' '
	+ ( SELECT  UPPER(Number.Number)
            FROM    Practice_Number
                    INNER JOIN Number ON Practice_Number.NumberID = Number.NumberID
                    INNER JOIN Admin ON Practice_Number.PracticeID = Admin.PracticeID
            WHERE   ( Number.NumberTypeID = 8 )
                    AND ( Admin.AdminID = @AdminID )
          )



[bookmark: _Toc448500137]Adding a segment of text
Form 4.31 has a section which has different wording for sole or joint Liquidators:
[image: ]
The pdf has been amended so that one field (“Appointed”) covers the text for the sole or joint options:
[image: ]
The listing below selects “I was appointed” or “we were appointed” depending on whether one, or more than one, appointee is attached to the job.
	Listing 5

	
INSERT INTO @Data
SELECT  'Appointed' ,
        CASE WHEN ( SELECT  COUNT(AppointmentTypeID)
                    FROM    dbo.Appointment
                    WHERE   ISNULL(Startdate, '') <> ''
                            AND ISNULL(Enddate, '') = ''
                            AND adminID = @AdminID
                  ) = 1 THEN ', I was appointed'
             ELSE ', we were appointed'
        END



[bookmark: _Toc448500138]Adding two fields plus text
The latest forms for registering a charge at Companies House include a section for the ‘short particulars’ of the property:
[image: ]
This could include the asset description and/or the asset title.  The listing below shows how this data may be presented:
	Listing 6

	
INSERT INTO @Data
SELECT 'Short_Particulars', 
   CASE WHEN ISNULL(Asset_Title, '') = '' 
        THEN 'Description and Address: ' + CHAR(13) + Asset_Desc
	ELSE 'Particulars of Title: ' + CHAR(13) + Asset_Title + CHAR(13) + CHAR(13) +
	     'Description and Address: ' + CHAR(13) + Asset_Desc
   END
FROM @SecCredData




	NOTE: The table variable @SecCredData must also be declared and populated from the charge data held.  See Listing xx below.



	Listing 7

	
DECLARE @SecCredData TABLE
(
  Admin_ID INT ,
  Contact_Title NVARCHAR(50) ,
  Contact_FirstName NVARCHAR(75) ,
  Contact_LastName NVARCHAR(75) ,
  Sec_Cred NVARCHAR(1000) ,
  Cred_Addr NVARCHAR(1000) ,
  Cred_City NVARCHAR(100) ,
  Cred_State NVARCHAR(100) ,
  Cred_PCode NVARCHAR(50) ,
  Instruction_Date DATETIME ,
  Lodge_Date DATETIME ,
  Charge_Description NVARCHAR(1000) ,
  Asset_Desc NVARCHAR(max) ,
  Asset_Title NVARCHAR(max)
)

INSERT  INTO @SecCredData
SELECT a.AdminID ,
	con.Title ,
	con.FirstName ,
	con.LastName ,
	cp.Name ,
	ad.Address ,
	ad.City ,
	ad.State ,
	ad.PostCode ,		
	aam.InstDate ,		-- Date Charge Created
	aam.LodgeDate ,		-- Date Reg'd at Companies House
	aam.InstDescription ,
	ass.TitleDetails ,
	ass.Description
FROM   SecurityAsset seca
	INNER JOIN Asset ass ON seca.AssetID = ass.AssetID
	INNER JOIN Security sec ON seca.SecurityID = sec.SecurityID
	INNER JOIN Admin a
	INNER JOIN AdminAppointmentMethod aam ON a.AdminAppointmentMethodID = aam.AdminAppointmentMethodID
	INNER JOIN Creditor c ON a.AdminID = c.AdminID
	INNER JOIN Address ad ON c.AddressID = ad.AddressID
	INNER JOIN Counterparty cp ON c.CounterpartyID = cp.CounterpartyID
	INNER JOIN Contact con ON cp.CounterpartyID = con.CounterpartyID ON sec.CreditorID = c.CreditorID
WHERE   ( ass.AdminID = @AdminID ) 



[bookmark: _Toc448500139]Splitting a date into days, months and years
Certain forms may have the day, month and year split into different fields:
[image: ]
The listing below takes the current date and splits it up accordingly:
	Listing 8

	
Insert Into @Data 
SELECT 'Today_Day', CAST(datepart(DD, GETDATE()) AS nVarChar(max))

Insert Into @Data 
SELECT 'Today_Month', CAST(datepart(MM, GETDATE()) AS nVarChar(max))

Insert Into @Data 
SELECT 'Today_Year', CAST(datepart(YYYY, GETDATE()) AS nVarChar(max))



[bookmark: _Toc448500140]Convert a date
The following listing turns a date in the format “dd/mm/yyyy” into “dd mm yy” to be formatted for certain fields, for example, a postal redirection form:
[image: ]
	Listing 9

	
Insert Into @Data 
SELECT 'Todays_Date', REPLACE(CONVERT(VARCHAR(8), GETDATE(), 3), '/', ' ') AS [DD MM YY]



[bookmark: _Toc448500141]Reformatting formatted address fields
In this example, the address field from the Meetings section in the application may have been formatted.  The pdf only allows for a single line of text.  The following listing shows how to remove any formatting from the relevant fields, adding back a comma where appropriate:
	Listing 10

	
INSERT INTO @Data
SELECT 'MeetLoc', 
	(SELECT MeetLoc = Replace(Replace(MeetingLocation, CHAR(13),''), CHAR(10),', ')  
		+ ', ' + Replace(Replace(MeetingAddress, CHAR(13),''), CHAR(10),', ')
	FROM dbo.Meeting
	WHERE MeetingID = @MeetingID)



[bookmark: _Toc448500142]Final steps:
Once the SP has been amended and checked, an additional segment may be added to the script.  This enables the script to determine
how and where the pdf may be run from, and
which types of job the pdf will be available in
The various options are shown below
1. The listing below provides an example of the MT import and Report definitions:
	Listing 11

	
EXEC gensp_MergeTemplateImport
	  @MTID = 315041 
	, @MTLocation = 3
	, @MTCat = 70000 
	, @MTDesc = 'Form 4.20 - Statement of Companys Affairs' 
	, @Extension = 'pdf' 
	, @DeleteExisting = 1
	, @MTPrecDesc ='<root>
				<sql>pdfsp_Form_4_20_statement_of_companys_affairs
					<parameters>
					</parameters>
				</sql>
			</root>'
	, @MTFlags = 524288
	, @ReportID = 315041
	, @MTReportCategoryID = 51000
	, @SystemFlags = 53

Delete From MergeTemplateAdminType Where MergeTemplateID = 315041

INSERT INTO MergeTemplateAdminType (MergeTemplateID ,AdminTypeID, TS) 
VALUES (315041, 4100, newid())

INSERT INTO MergeTemplateAdminType (MergeTemplateID ,AdminTypeID, TS) 
VALUES (315041, 4105, newid())


Delete From ReportAdminType Where ReportID = 315041

Insert Into ReportAdminType (ReportID ,AdminTypeID, TS)
Select 315041, 4100, NEWID()

Insert Into ReportAdminType (ReportID ,AdminTypeID, TS)
Select 315041, 4105, NEWID()
GO



2. This section creates the definition for the MT:
EXEC gensp_MergeTemplateImport
	  @MTID = 315041 
	, @MTLocation = 3
	, @MTCat = 70000 
	, @MTDesc = 'Form 4.20 - Statement of Companys Affairs' 
	, @Extension = 'pdf' 
	, @DeleteExisting = 1
	, @MTPrecDesc ='<root>
				<sql>pdfsp_Form_4_20_statement_of_companys_affairs
					<parameters>
					</parameters>
				</sql>
			</root>'
	, @MTFlags = 524288
	, @ReportID = 315041
	, @MTReportCategoryID = 51000
	, @SystemFlags = 53
The various settings, and how you get to them, are described below.
3. This script will identify the Merge Template ID, Merge Template category and other variables required for the Merge template import routine:
	Listing 12

	
SELECT  *
FROM    dbo.MergeTemplate
WHERE   Description LIKE 'Form 2.30B%'
        AND Extension = 'pdf'



The results from this script are effectively as set in Manage Document Templates.
	Script variable
	Table field
	

	@MTID
	MergeTemplateID
	The MT reference identity, obtained from Listing x

	@MTLocation
	LocationID
	The location of the Practice:
Australia = 1
UK = 3
All locations = 99

	@MTCat
	MergeTemplateCategoryID
	The category for the MT, or where the MT is shown on the folder pane in Manage Document Templates.
For PDF MTs, this will always be 70000.

	@MTDesc
	Description
	The MT’s file name, excluding the file extension.

	@Extension
	Extension
	The file extension, in this case, pdf (without the preceding dot).

	@MTPrecDesc
	PrecidentActionDescription
	This is the SQL script passed to the application when the MT is being prepared.
See section 4 below.

	@MTFlags
	Flags
	The value here depends on the various options set in Manage Document Templates.  
See section 5 below.

	@ReportID
	MergeTemplateID
	The MT reference identity, this time for creating a report reference to the MT.  See listing 

	@MTReportCategoryID
	ReportCategoryID
	The Report Category indicates where MT will be shown on the Reports and Forms menu.

	@SystemFlags
	SystemFlags
	<internal>


4. For the @MTPrecDesc section, the following parameters are used:
	Custom Field Type
	Data Type
	Example XML text

	Options:
	36
	<parameter prompt="Were you appointed over the whole pr part of the comapny''s property?" datatype="36" sqlparameter="@How_Appointed" options="whole|part"/>

	SQL Script:
	
	<not implemented>

	Date:
	7
	<parameter prompt="Please enter the VAT input from date" datatype="7" sqlparameter="@FromDate"/>

	Number / Text:
	8
	<parameter prompt="Enter the address of the scheme Trustee or Manager, excl postcode" datatype="8" sqlparameter="@TrusteeAddress"/>

	Multiple lines of text:
	9
	<parameter prompt="Enter the short particulars from the charge document" datatype="9" sqlparameter="@ShortParticulars"/>


The @MTFlags parameter relates to the various settings in the ‘User Prompts’ settings of ‘Manage Document Templates’ and probably easiest set manually then recovering the settings using Listing xx above.
	NOTE: To obtain the value for @MTFlags manually, the  following values for the various User Prompts selection values are used:
	User Prompt
	Value

	Meeting
	16834

	Dividend or Distribution
	32768

	Appointee
	65536

	One or More Signatories
	131072

	One Signatory only
	524288

	Retired Appointee
	1048576

	Contribution
	33554432

	Asset
	67108864


So, if the ‘Meeting’ and ‘One Signatory Only’ are selected, the value for @MTFlags will be:
	Meeting			16384
	One Signatory Only	524288
	@MTFlags value	540672
Similarly, selections for ‘Dividend’, ‘One or More Signatories’ and  ‘Assets’ will result in a value for @MTFlags of 67272704 (32768 + 131072 + 67108864).
However, you may not select ‘Appointee’ and ‘Retired Appointee’ together, for obvious reasons.


5. The value for @ReportID is generally the same as for the MT ID, but there is no requirement for it to be the same.
If this is a new pdf, you should probably overwrite the old pdf, so a search for the old pdf, which can be found using listing xx below, substituting the required pdf’s name for that shown in the listing:
	Listing 13

	
SELECT  *
FROM    dbo.Report
WHERE   MergeTemplateID = ( SELECT  MergeTemplateID
                            FROM    Mergetemplate
                            WHERE   Description LIKE 'Form 4.20 %'
                                    AND Extension = 'pdf'
                          )



If the pdf is new, a new ReportID should be assigned.  Confirm the next free row with the following listing:
	Listing 14

	
SELECT  *
FROM    dbo.Report
ORDER BY ReportID DESC




	NOTE: The value of ReportID should be in the same range as similar pdf forms – between 300000 and 500000.  


6. The value for @MTReportCategoryID can be obtained from the following listing:
	Listing 15

	
SELECT * FROM dbo.ReportCategory



7. The following sections define the job types in which the MT and Report is displayed.  The MT job type is defined here …
Delete From MergeTemplateAdminType Where MergeTemplateID = 315041

INSERT INTO MergeTemplateAdminType (MergeTemplateID ,AdminTypeID, TS) 
VALUES (315041, 4100, newid())

INSERT INTO MergeTemplateAdminType (MergeTemplateID ,AdminTypeID, TS) 
VALUES (315041, 4105, newid())
… and the Report job type is defined here:
Delete From ReportAdminType Where ReportID = 315041

Insert Into ReportAdminType (ReportID ,AdminTypeID, TS)
Select 315041, 4100, NEWID()

Insert Into ReportAdminType (ReportID ,AdminTypeID, TS)
Select 315041, 4105, NEWID()
The MergeTemplateID and the ReportID are as identified in previous sections.  The job type can be identified using the following script:
	Listing 16

	
-- For UK Job Types 
SELECT * FROM dbo.AdminType
WHERE LocationID IN (3,99)

-- For Australian Job Types 
SELECT * FROM dbo.AdminType
WHERE LocationID IN (1,99)




	NOTE: the values of -1 (all job types), -2 (all corporate jobs) and -3 (all personal jobs) may also be used.


[bookmark: _Toc448500143]Testing
Once the pdf and script have been built, the output needs to be tested.
1. Ensure the pdf has been saved in the Forms subdirectory of the current testing Merge Templates area.
2. Run the script against the current testing database.
There should be no errors in the script, so any errors need to be corrected.
3. Confirm the SP has been registered against the database.
Open the node [testing database] > Programmability > Stored Procedures and navigate down until the “pdfsp_” section is shown (there should be a number of these SPs).
4. Make sure it’s properly registered.
Right-click on the Stored Procedures node and click Refresh.
[image: ]


5. In the application, click Refresh:
[image: ]
6. Make sure the report is visible in the required job type.
It may be worth setting the job type to ‘all’ (-1) just to confirm the script works without error and the pdf populates correctly before defining which job types it will be available in.
7. Run the report.
Obviously there should be no errors at this stage.  Usual errors relate to:
Missing variables – defined in the script but not defined in the @MTPrecDesc section.
Incorrect or mismatched naming of variables in the script – check both the main body of the script, the EXEC gensp_MergeTemplateImport section (particularly the @MTPrecDesc section) and the pdf form field names.
Mismatched file names – the name declared in the script (@MTDesc) does not match the actual file name
Any error may refer to an issue with incorrect or missing @AdminID, followed by a ‘Cannot find file’ error.  This will be due to any problem, not just with @AdminID, so every possible issue with the script and pdf should be checked.
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