MYOB Accountants Enterprise

Insolvency
Hotfix

Installation Guide




Copyright 2009 MYOB Technology Pty Ltd. All rights reserved.

Disclaimer

MYOB has made every attempt to ensure the accuracy, relevance and completeness of this material but excludes (to the extent
allowed by legislation) any warranties regarding it. Furthermore MYOB, its staff and agents shall not be liable for any loss, cost or
damage (however incurred including negligence) arising out of errors or omissions in the material, especially if such materials
contain information sourced from third parties or the ATO. In some cases the materials provided contain case studies (applying
particular accounting standards or legislation) and anecdotes which may not directly apply to the user's circumstances and are
used as representative examples only and should not be considered as authoritative advice regarding any accounting standard,
law or industry opinion. MYOB advises that if the user wishes to rely on the case studies contained in the material then it must
seek professional advice before doing so. Furthermore reliance on the representative examples in the seminar materials is at the
user's own risk.

Copyright
Furthermore the seminar and materials may not be copied, altered, edited, disposed of or distributed without the prior written
consent of MYOB.

Trademarks

All trademarks used in this material are owned by MYOB Technology Pty Ltd or the indicated registered owners of the trademarks.
Users are forbidden from using, copying or transporting the trademarks without express prior written consent. AppleShare and

Macintosh are registered trademarks of Apple Computer, Inc., registered in the United States and other countries. LiveLinks is a

trademark of Ceedata Holdings Pty Ltd. Microsoft, MS-DOS, Windows, Windows NT, Windows BackOffice and Outlook are either
registered trademarks or trademarks of Microsoft Corporation in the United States and other countries. Novell and Netware are
registered trademarks of Novell, Inc.

MYOB Technology Pty Ltd ®
ABN 30 086 760 269
Level 13, 383 Kent St
SYDNEY, NSW, 2000

MYOB Accountants Enterprise Insolvency Hotfix Installation Guide
Printed: 28 April 2009



Contents

OV VI BW . . 4
Installation ... ... .. 4
Phase 1 — Preinstallation . . ...... ... ... 4
Checking Prerequisites . .. ... ...ttt e e e 4

Files Required . . ... it e e 5

Full System Backup . ... ..o e e 5

Phase 2 — Installation . ... ... ... ... e 8
Installing the Hotfix . ... ... . . e e 8
APPENIX . oo 13
Appendix A — Restoring a Database via SQL Server . ....... ... ... . . . .. i ... 13
Appendix B — Restoring a Database via SQL 2005 Server . ......... ... ..., 15

MYOB AE Insolvency | Hotfix Installation Guide | 3



Overview

Overview

This document should be read in conjunction with specific details about the Hotfix
you are about to install on your system. These details were supplied to you by MYOB
with this Installation Guide and include:

e The name of the Hotfix
e Who the Hotfix is for
e What the Hotfix will do

e The version of Insolvency to which the Hotfix may be applied (prerequisite)

Note: Ensure that the Hotfix is compatible with the version of MYOB Insolvency that
is running on your system. Some Hotfixes may be applied to all versions of
MYOB Insolvency, but usually they are specific to a particular version (e.g.,
Version 3.0.93).

Installation

Phase T — Preinstallation

In the preinstallation phase, you should do the following:

e Ensure your system has the relevant pre-requisites. Refer to Checking
Prerequisites.

e Obtain the Hotfix file from MYOB. Refer to Files Required.

e Perform a full system backup. Refer to Full System Backup.

Checking Prerequisites

Consult the Systems Requirements page on the MYOB website to ensure that MYOB
supports your setup environment:

http://myob.com/servlet/
Satellite?cid=1111356364276&attrname=SystemRequirements&pagename=MYOB
%2FProduct%2FAccountantProduct&site=en_AU&c=Product.

Note: If your system is not listed in the System Requirements page, you may
experience installation and configuration problems, or MYOB software
functionality may be limited or give unexpected results.

In addition to the system requirements listed on the MYOB website, ensure that the
Hotfix is designed to be applied to your version of MYOB Insolvency.
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Installation

Files Required

The Hotfix script can be obtained by contacting MYOB Support on the Support
Hotline 1300 555 666.

If the update script is supplied to you in .ZIP format, it must be unzipped before it can
be run. To do this, right-click the .zip file in Windows Explorer and select Extract all
.... Follow the Extraction wizard’s instructions and ensure that the script is extracted
into the desired folder.

Note: Copying Hotfix files to a standard location on the server is good practice which
ensures all software updates are stored in one central place.

Full System Backup

A full backup of your system should be taken before installing the Hotfix.

Separate instructions are provided for standard MS SQL Server (below) and MS SQL
Server 2005 (See To Perform a Full System Backup on MS SQL Server 2005 on page 6.)

To Perform a Full System Backup on MS SQL Server

1. Ensure all users are logged out of MYOB Insolvency.

2. Click Start > Programs > Microsoft SQL Server > Enterprise Manager.
3. Expand the folders until you locate the database INSOL2.

4. Right-click the database and click All Tasks.

5. Click Backup Database.

The SQL Server Backup — Insol2 window opens.
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Installation

6. Under Destination, click Remove if there is a file name as illustrated below.

SOL Server Backup - Insol2

General ] Options ]

Database: l Insal2 :_J
MName: ]InsoIZ backup
Description: I

Backup

+ Database - complete
" Database - differential

Destination
Backup to: = Tape = Disk
Add...
Remove
Cortents...
COvenwrite
Schedule
Help ]

7. Click Add.
The Select Backup Destination window opens.

8. Select a location and type a name for the backup in File name.

Select Backup Destination

Select the file name or backup device to use for the
g backup operation. Backup devices can be created for files
that you use frequenthy.

(* File name:
1(3:"-.Databases"-databasebackup
" Backup device:
oK | Cancel |

9. Click OK.
10. Select Overwrite existing media and click OK.

11. Click OK.

To Perform a Full System Backup on MS SQL Server 2005

1. Click Start > Programs > Microsoft SQL Server 2005 > SQL Server
Management Studio.

The Connect to Server screen opens.
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Installation

2. Click Connect.

The SQL Server Management Studio Express screen opens.
3. Expand the folders until you locate INSOL2.
4. Right-click the database and select Tasks > Backup.

5. Under Destination, click Remove if there is a file name present, as shown below.

T Back Up Database - Insolll g@
Selectapage Ie . =
Script > L[5 Hel
2 General 5 o g
ﬁ Options
Source
D atabase:
Recovery model: | |
Backup type: | Full Eva |
Backup component:
(3) Database
Backup set
Name: Insoll-Full D atabase Backup |
Description: ‘ |
Backup set will expire:
L e a—
Server: Destination
WMWAREWINAPYWSOLEXPRESS X
Back up to: @ Disk.
Cornection - — —
WM AREWIMAP A dmiristratar C:Pro = 5 55 ]
4 View connection properties
Ready
< >

6. Click Add.

The Select Backup Destination window opens.

7. Click ..., then navigate to the backup destination.

8. Enter a name for the backup in File name.

¥ select Backup Destination E]

Select the file or backup device for the backup destination. Y'ou can create
backup devices for frequently used files.

Destinations on dizk
& File name:
| C:\Program Files'bicrosalt SUL ServertMSSOL 1\MS5UL Backu| [ .

oK ] [ Cancel
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Installation

9. Click OK.
10. Select the Options tab.

11. Select Overwrite all existing backup sets and click OK.

Phase 2 — Installation

Read this section completely before starting the installation. It will help you plan for
the tasks required to successfully install the MYOB Insolvency Hotfix.

Installing the Hotfix

There are two ways you can install the update script:

e From the Insolvency Update Utility (see page 8).

e Using SQL Server Management Studio Express (see page 10)

From the Insolvency Update Utility

Note: The update script can be run on one workstation with full administration rights
to the server.

1. Ensure all users are logged out of MYOB Insolvency.
2. Click Start > Programs > MYOB > Insolvency > Update Utility.

The Update Database window opens.

8 Update Database |§|
Flease browse for the update file then enter details of the server and

database and enter the user name and password of a user authorised
to make database updates,

Server: .
Database: -
User Mame:

Password:

==l | [ ]

3. Click ... to add all available server options to the Server drop-down list.
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Installation

4. Select the server name for the Insol2 database from the drop-down.

Flease browse for the update file then enter details of the server and
database and enter the user name and password of a user authorised
to make database updates,

Server: (localy -
Database: -
User Mame:
Password:
’ Cancel ” ] ’ Browse ]

53] Update Database le

The name Insol2 should be listed in Database. If it is not, type Insol2.

Flease browse for the update file then enter details of the server and
database and enter the user name and password of a user authorised
to make database updates,

Server: (localy -
Database: | Insol2 -
User Mame: |
Password:
’ Cancel ” ] ’ Browse ]

53] Update Database PS_<|

5. Enter your Microsoft SQL Server User Name (usually sa) and Password.

6. Click Browse.

7. Navigate to where you have stored the MYOB Insolvency Hotfix file and click
Open.

Lookin: | (9 1.1.0 |
! [ L1050
| 3 [] Hotfix 1.1.03 GEMERAL.sql
My Recent (%] Hotfix_1.1.04 GEMERAL.sal
Documents
Desktop

My Network  File name: |

Fies of type: | SGL Update Files {"sdl)

8. Click Update.
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Installation

The Update successful window opens.

9. Click OK.

Using SQL Server Management Studio Express

Note: The update script can be run on one workstation with full administration rights

to the server.

Ensure all users are logged out of MYOB Insolvency.

Click Start > Programs > Microsoft SQL Server 2005 > SQL Server

Management Studio Express.

The Connect to Server window opens.

£F Connect to Server

Microsoft 4 Windows Server System
SQL Server200s

Server type: | [Databaze Engine

205 vD0 1

Server name:

Authentication: | windows Authentication v |

[_

Connect ][ Cancel H Help H Options »»

Ensure you login credentials are correct and click .

The Object Explorer will display.

2 3 I 2]
= [B ALUSYDOO1367M (SOL Server 9.0,4035 - ALUSYDOO1367)
= [ Databases
[# [ System Databases
H | 1410432763
& | | Insol2
& | Jan
[# iJ
[# [ Security
[# [ Server Objects
# [ Replication
[# [ Management
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4. Expand the Databases folder, right-click on your Insolvency database and select
New Query.

A new query tab will display.

5. Ensure the correct database is displayed in the dropdown.

A= H | E o8 23 =D 8 i | o =2 ‘le |RR |v| ¥ Execute ;E:
| “AUSYDO01367N.... SQLQueryl.sql| Summary | L — X
IF Available Databases l}
A
8|
< 2|

6. Click File > Open > File.

Open File
Lock in: |||j Huotfix V| @ - Q X Ci B~ oTeoks~

= Mame  ~ Size  Type
U‘B =y |Ho 90504 1 KB Microsoft SQL Sery

Desktop

-

My Projects

My Computer

8 | >
File: name: | w | [ Cpen f'_]
Files of bype: |,q|| Files (*,*) v | Cancel ;
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7. Navigate to where you have stored the MYOB Insolvency Hotfix file and click
Open.

The Hotfix script will display in a new tab.

2= = : = =l - 2 {5z RR - B Execute

AUSYDDD1367N.RR - P:\...\Ho...qi AUSYDOOL367M, ... SQLQueryl,sql Summary - X
thiceltese s AR S 1= RSk g -
~

Insert Into dbo.S3cripts
¥alues ('Hotfix 090309 SR 1426952693 AlexFreight Inselvencydob. Leased Assets', GetDake
Go

Declare BEnt Table (EntryID Int)

Inzert

Into BEnt

Select Distinet

EntryID

From SubEntry

Where Account AccountID In(l46242,146240)

Delete SubEntry

From SubEntry se

Inner

Join BEnt et

On et.EntryID = se.EntryID

Delete Entry

From Entry se

Inner

Join BEnt et

On et.EntryID = se.EntryID

Exec gensp EBalancelLEdger 1217

8. Click ¥ Execute

The script will run and the Query executed successfully icon will display.

L3 Messages
{1 rowis) affected)
(7 rowi(s) affected)
(14 rowis) affected)
(7 row(s) affected)
(31 rowi(s) affected)
(2% rowi(s) affected)

(0 row(s) affected)

I'a Query executed successfully. ] AUSYDOO3EFN [9.05P3] | AUSYDOOT 367N staff. member (53] RR  00:00:09 | Orows

9. Close SQL Server Management Studio Express.
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Appendix

Appendix

Separate instructions are provided for standard MS SQL Server (below) and MS SQL
Server 2005 (page 15).

Appendix A — Restoring a Database via SQL Server

1.

2.

Click Start > Programs > Microsoft SQL Server > Enterprise Manager.

Expand the folders until you locate the database INSOL2.

Right—click and select All Tasks.
Select Restore Database.
Select From device.

Click Select Devices ...

Restore database El

Generd ] Options I

{% Restors ae database:  [Inaci2 -1

Aestors: " Databass " Flegrups or files % From devies

Pamametes

Devices: ‘

l_..

{* Resiore backup sst
@+ Database - complete
" Database - differertial
" Transaction log

¢ fils orfilsgmup

" Read backup szt information and add to backun histo

oK Cancel Help

MYOB AE Insolvency | Hotfix

Installation Guide | 13



Appendix

7. Click Add ..

Choose Restore Devices

Media verfication option

When the backup is restored, SQL Server will attempt to restors from the
cdevices listed below

Backup sat: {Unknown)

Restore from % Digk € Tape

I™ Orly restars from media with the following name:

Device name | Add.

OK Cancel

8. Click ... then browse to the database location.

9. Select the file name of the database and click OK.

Select Backup Destination

' File name:

Select the file name or backup device to use for the
g backup operation. Backup devices can be created forfiles
that you use frequently.

" Backup device:

|C." Databases'databasebackup -

=l
s |

10. Click OK.

Choose Restore Devices @
il When the baclkup is restored, SQL Server will attempt to restare from the
devices listed below

Backup sst

Restore from:

Media verfication option

I Only restore from media with the following name:

{Linkniowr)
" Disk € Tape
Device name Add...
C:\Databases'databasebackup

Remove
Remove All

0K Cancel

11. Select the Options tab.

12. Check Force restore over existing database.
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Appendix

13. Click OK.
Restore database @
General  Options ]
[ Bect tapes (if any) afterrestonng each backup
I F
W Force restore over existing database
Festore database files as Read from meda
Lagical file name Mave to physizalfile name \

Recovery completion state

(¥ | eave database operational. Mo addttional transaction logs can be restorzd
" |Leave database nonoperational but abls to restors additional transaction logs.

(" Leave database reed-only and able to restore addticnal transacticn logs

| =

If your SQL databases are stored in a different location, specify the correct
location under Move to physical file name

Appendix B — Restoring a Database via SQL 2005 Server

These instructions apply only to users running a MS SQL 2005 Server. All others
should refer to Appendix A — Restoring a Database via SQL Server on page 13.

1. Click Start > Programs > Microsoft SQL Server 2005 > SQL Server
Management Studio.

Connect to Server screen opens.
2. Click Connect.

SQL Server Management Studio Express screen opens.
3. Expand the folders until you locate the database to be restored (e.g., INSOL2).
4. Right-click INSOL2 and select Tasks > Restore > Database.

The Restore database screen opens.
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5.

Select From device.

estore Database - Insolll

Select a page
General

S Script ~ Help

EBX

Deestination for restore

Select or type the name of a new or existing databagse for your restore operation.

[

To database:

To a point in time: |MDsl recent possible

Source for restore

Specily the source and localion of backup sets to restore.

(%) From database: ‘ Insalll

) From device: ‘

Select the backup sets to restare:

MHame Component

Restore

Inzalll-Full Database Backup

Server
WIMWAREWIN<PA\SOLEXPRESS

Cannection:
WhAWAREWINP A dmiristrator

_‘Qj Wiew connection properties

Progress

Ready

Type | Server
Database Full

WWAREWIN:PLSOLEXPRESS

>

Click ..

The Specify Backup screen opens.

== Specify Backup E]

Specify the backup media and its location for our restore operation.

e |8

Backup media:

Backup lacation:

” Cancel ][ Help

Click Add.

The Locate backup file screen opens.

Select the database to be restored (e.g., Insol2).

Click OK.
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10.

The Specify backup screen reappears, with the database selected.

== Specify Backup rz|

Specify the backup media and its location for your restore aperation,

[Fie |

Backup media:

Add

|A
(£2

Ok ][ Cancel ][ Help

Click OK.

11. Toggle the Restore box to indicate which database you want to restore when
there is more than one database.

._' Restore Database - Insolll

Selectapage
29 General

;S Script = Help

ﬁ Options

Destination for restore

Select or type the name of a new or existing database for wour restare operation,

To database: |\nsul|\

To a point in time: |Mnsl recent possible

I()

Source for restore

Specify the source and location of backup sets ta restare.

() From database:

Server
WMWAREWINAPYWSOLEXPRESS

Connection
WMWAREWINXPhbdministrator

4 View connection properties

Progress

Ready

(&) From device: C:4Program Fileshhicrozoft SOL ServertyhWSSOL 1S5S | E]

Select the backup sets to restore:
Restare | Mame

Server
AUSYDOI1SAPPS
WMWAREWINXPYSELEXPRESS

Compaonent | Type

Insol2-Full D atabase Backup  Database Full
Insol2-Full Database Backup  Database Full

< *

12.

13.

14. Click ...

15.

Select the Options tab.

Select Overwrite the existing database.

Locate the data and log file respectively.
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16. Click OK.

B Restore Database - Insolll

Select apage

5 Soript [ Hel
General ‘5 P .
Options

Restare options

Owerwite the existing databaze

[[] Preserve the replication settings

[] Prampt before restaring each backup
[] Restiict access ko the restored database

Restore the database files as:

Original File Name Restore Az
ims_Dhata C:\Program FilestMicrosoft SAL Serverts... E]
ims_Log

C:\Pragram Files\Microscft SOL ServertMS... E]

Recovery state

® Leave the database ready to uge by roling back uncommitted transactions. Additional

Server transaction logs cannot be restored (RESTORE WITH RECOYER'Y]

WhWAREWIN:PAS OLEXPRESS

Connection: i @) Leave the database non-operational, and do not roll back uncommitted tansactions. Additional

WAWAREWINXP A dministrator transaction logs can be restared. [RESTORE WITH NORECOWERY)

3 View connection properties

Leave the database in read-only made. Undo uncommitted ransactions, but save the undo

actiohs in a standby file za that recovery effects can be reverzed [RESTORE 'WITH STANDEY)

Togress

Ready
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